showing posts tagged with 'hardware'
edited by on April 8th 2016, at 17:22
Mac OSX 10.10.4 introduces TRIM support for third party SSDs. Until then, you had to use third party tools such as Trim Enabler in order to get TRIM on your SSD.

By default, when replacing your HDD with a third party SSD (i.e. an SSD not from Apple), TRIM is still not enabled. But you can run a simple command from a Terminal which will do just that:

sudo trimforce enable

This will enable TRIM on any SSD that supports it. Note that you will have to reboot for the changes to take effect.

If you wish to disable TRIM (why on earth would you do that?), you can run the same command, replacing enable with disable.

Note that trimforce does not completely replace Trim Enabler as it only enables   ...
edited by on October 14th 2015, at 09:53
Microsoft has announced the next generation of their tablet: the Surface Pro 4. It features the new 6th generation Intel CPU, higher resolution, more storage, memory, and an improved (back-lit) Type Cover. Prices start at $899 in the US.

→ Surface Pro 4 specifications

Also from Microsoft, is its all-new Surface Book, a 13.5" hybrid ultrabook, and basically the direct competitor to Apple's Macbook. Featuring a high resolution (3000x2000), 6th gen Intel CPU, two full-size USB 3.0 ports, SD card, and much more. The i5/i7 models even come with nVidia GeForce graphics.

→ Surface Book specifications

With its sleek design, and powerful features, it is obvious that Microsoft is fi  ...
edited by on September 25th 2015, at 10:00

You can check the warranty and support contract status of your HP products online. This includes the base warranty, support contracts and/or carepacks.

edited by on July 10th 2015, at 12:35

No_Light means there's no link on the port. Usually this indicates a problem with the physical wiring, either a faulty cable, or the TX/RX have been swapped.

No_Sync means there's a link on the port (so technically, wiring is okay), but there's a problem with the actual communication. The most common problem is a mismatch in speed on the switch port and the HBA on the other side. Your best bet would be to set the port's speed (temporarily) to auto-negotiate and see what speed is selected. If this does not work, try manually setting the port fixed to lower speeds.

edited by on July 7th 2015, at 14:21

It may be useful to know whether your Mac has a 32-bit or 64-bit EFI. This can be done by running the following command from an OSX Terminal (can run from the installer or recovery partition):

ioreg -l -p IODeviceTree | grep firmware-abi

This should return something like the following:

• For 32-bit EFI:  | | "firmware-abi" = <"EFI32">
• For 64-bit EFI:  | | "firmware-abi" = <"EFI64">
edited by on June 30th 2015, at 15:15

Recent models of Mac boot up with a black boot screen and white Apple logo, instead of the old gray and dark gray boot screen. DarkBoot enables older Mac systems to get the black boot screen as well. For newer Macs, the app can also change the boot screen back to the traditional gray color.

  1. Download latest release of DarkBoot.
  2. Unzip and run the DarkBoot app.
  3. Select the desired color, then click OK.
    You will be prompted for the admin password. Enter it and press OK.
  4. Reboot twice for changes to take effect.

Known to work with OSX 10.10 and 10.11 DP.

edited by on April 28th 2015, at 15:24
This article is a quick reminder (for myself) on how to properly configure port forwarding on a Dell Sonicwall firewall.

First, create the address and services objects you need for the port forwarding. In case of multiple addresses or services, create a group and add all objects in that group.

Address object for a local server

Service group with multiple services

Predefined objects, such as the WAN IP are already present and do not have to be created again. Also, the advantage of using these predefined objects is that they are dynamic: e.g. if the WAN IP changes, the policies and rules that use this object will not have to be changed.

Once the objects are in place, they can be refer  ...
edited by on April 27th 2015, at 10:59
Smartcard readers that use the OpenSC PCSC daemon in order to work may no longer work after upgrading your Mac OSX to Mavericks (10.9). This is because of a problem that occurs with the PCSCD after the upgrade. Affected card readers are all that use this daemon for its communication. Examples are most ACR38U-based card readers, certain Vasco DIGIPASS readers, and some others.

The solution is to re-install the PCSCD package, which will fix corruption and make sure the daemon is started properly, enabling the card reader again.

Download the PCSCD-autostart package from the Vasco website.

Install this package. Note that you may have to circumvent the built-in application security, as  ...
edited by on April 20th 2015, at 15:41

You can disable the page prompt "--More or (q)uit--" by entering the following command at the console:

terminal length 0

This disables the prompt, and allows you to do config dumps, or run show tech-support.

If you get an error about unrecognized command, your firmware is too old.

edited by on April 17th 2015, at 15:07

Dell Networking switches introduce a new port mode called switchport general. This type is a multi-purpose mode, combining access and trunk in one.

Access mode

The following gets written as:

switchport mode access
switchport access vlan 99
switchport mode general
switchport general allowed vlan add 99 untagged
switchport general pvid 99

Trunk mode

The following gets written as:

switchport mode trunk
switchport trunk allowed vlan add 99,100
switchport mode general
switchport general allowed vlan add 99,110 tagged
switchport general pvid 4095         (this is is the drop vlan)
edited by on March 17th 2015, at 08:10

I followed this guide to replace the HDD on my Mac Mini (2009, aka model A1283):

The most tricky part is probably opening up the Mac. As I did not have a putty knife at hand, I used a rack cage nut mounting tool to create an opening,  and a very thin flathead screw driver to pry the case off, as explained in the guide.

EDIT: added picture of tool.

edited by on February 5th 2015, at 10:38

For my own reference, the port and LED layout of a Belgacom/Proximus B-Box 2 wireless router:



edited by on October 13th 2014, at 12:46
Installing a firmware upgrade on your Dell Force10 MXL IOM works similar (but slightly differently) than the other Force10 series. There are two things to upgrade: the IOM firmware and IOM operating system. The first has to be upgraded through CMC (not documented here), the second through the switch itself.

To upgrade FTOS, you need console access (can be SSH/Telnet) to the switch and an SCP/FTP/TFTP server.

If you have none of these, you can download tftp32/64. This is a light-weight TFTP-server which does not need to be installed and can be run as an application on any networked computer. Place the downloaded firmware (the BIN-file) in the same location as the tftp32/64 executable and st  ...
edited by on June 25th 2014, at 14:10

A very interesting read about Wi-Fi implementations and its pitfalls in larger deployments, in particular about the usage of channels and the importance of channel plans.

edited by on February 11th 2014, at 13:52

To get this card running on Windows Server 2012 and 2012 R2, you need this driver:

Newer versions no longer seem to support this card.

edited by on February 5th 2014, at 13:01
Newer generations of HP Proliant servers (I had this with an ML110 G6) no longer show I/O controller messages directly on screen. Instead, they are masked by a graphical status screen.

Not having these messages also means you won't know when you have to hit that certain key (F8) to get into the RAID controller's configuration BIOS, which can be problematic.

To get out of the graphical status screen and see all the I/O messages, you can hit Space on your keyboard during startup. For me, this usually did not work right away, and I had to hit the key multiple times before it got out of the status screen.

When done correctly, you'll notice the I/O messages and intialisation messages of the RA  ...
edited by on September 11th 2013, at 15:11

If you have an HP laptop with an unknown device with hardware-id HPQ6001, it's the HP wireless button driver. Apparently some models on their support website lack this driver in the download list (it was the case for a HP Envy Touchsmart 1230eb).

Direct link to download:

edited by on September 11th 2013, at 15:02

If you happen to stumble upon an unknown device in Windows Device Manager with a hardware ID of ACPI\INT33A0, it's the Intel Smart Connect Technology device. Download its driver from Intel or from your manufacturer's website.

edited by on August 22nd 2013, at 15:53

A note about installing the drivers for the Dell PowerVault TL2000/4000 on a Windows 2012 machine.

You can download the firmware from the Dell Support website. After extracting the package, do not install the driver using Device Manager. Doing so will not properly install the drivers (results in error code 37). Instead, install them using the included executable (install_nonexclusive.exe). Running this (elevated) will install the drivers the proper way, and the devices will start correctly.

edited by on August 21st 2013, at 10:18
I've encountered several issues on different HP Elitebook Folio 9470m ultrabooks, after updating the BIOS to its latest version (F.46).

One series of ultrabooks with an Intel Hybrid HD (with SSD cache) suddenly stopped working with a BSOD and refused to startup. Reinstallation with the original DVD oddly failed as well, either during installation, or after installing drivers. We've worked around the issue by using a Microsoft (non-HP) DVD to install Windows 8, then download the latest drivers from the HP site.

Another ultrabook with an SSD had another problem altogether, but still related to the BIOS update. After the update, USB devices started to fail intermittently. Both the   ...
showing posts tagged with 'hardware'
« May 2024»
« Have you tried turning it off and on again? »
The IT Crowd