showing posts tagged with 'windows'
edited by on December 28th 2007, at 21:46

For all nVIDIA users, I suggest installing the hotfixes recommended by nVIDIA: link.

If you have SLI, first install KB936710 (that's hotfix 2 on the nVIDIA page).

Most importantly, install KB940105 (hotfix 1).

And finally, there are KB938194 (hotfix 3), and KB938979 (hotfix 4).

edited by on November 11th 2007, at 20:24
A Terminal Server can be put in two modes:

execute mode: this is the default mode. In this mode, users can log in the TS and run applications.

install mode: putting a server in this mode will notify the TS of changes in the system when installing software. This is important, because otherwise software would fail to properly get installed, and there would be all kinds of ugliness going on.

In Windows 2003, a server should automatically be put in to install mode if your installation software has setup, or install in their file name. In Windows 2000, you have to put the server in the correct mode, by installing software using Add/remove programs in the Windows control panel. Note that in Win  ...
edited by on November 11th 2007, at 19:46
When running Photoshop CS2 on a Windows 2003 with Terminal Server, regular users cannot start Photoshop CS2. If they try, the following error is displayed:

An error has been detected with a required application library and the product cannot continue. Please reinstall the application

However, when running with Administrator privileges, there is no problem.

CS2 requires the SeCreateGlobalPrivilege privilege. By default, regular domain users don't have this privilege, and thus, CS2 doesn't work.

Assign the required privilege to the users. Normally, assigning this privilege to trusted users should not give any security problems. I do suggest creating a new security group and assign th  ...
edited by on November 5th 2007, at 23:01
After installing Microsoft .NET Framework 2.0 on a Windows 2000 Server, I got a flood of Event ID 1008 in the Application system log. These log entries complain about performance counters not being able to be properly initialized.

First, try running these two commands sequentially from an NT console:

winmgmt /clearadapwinmgmt /resyncperf

Because it didn't work for me, I worked around the issue by disabling the performance counter for the particular ASP.NET services. For this, you need to download an application of the Windows 2000 Resource Kit Tools for administrative tasks, called Extensible Performance Counter List (exctrlst.exe).

After downloading (and installing) the tool, start it  ...
edited by on November 5th 2007, at 22:16
Had this issue with one of my clients: he was unable to open spreadsheets from his desktop or from his Windows Explorer. Double-clicking on the file opens a new, empty Excel session, and an error message is displayed.
After a quick search on the Microsoft support site, I found a solution.

When attempting to open an Excel spreadsheet from the desktop or from Windows Explorer (or any other program), a new, empty Excel session is started, and an error message is shown:

Cannot find the file path (or one of its components). Make sure the path and filename are correct and that all required libraries are available.


Windows cannot find FilePathFileName, Make sure you typed the nam  ...
edited by on August 2nd 2007, at 15:55
If you ever had the need to automatically reboot your system (whether it's a workstation or a server), knows that this is not a very simple thing to do. The shutdown command of Windows is often limited (e.g. it can't be used when nobody is logged on, or when the system is locked), and other applications are often too complex, or not free, or may even contain spyware and other ill-made wares. Windows Sysinternals has a solution.

The application is called PsShutdown, and is downloadable for free:

PsShutdown is quite similar to "regular" shutdown - the former accepts the same parameters as the latter, but has various add  ...
edited by on June 11th 2007, at 11:37
In linux, punching in uptime provides you with how long the system was up without a reboot. But how to do this in Windows? There is no real indication to be found anywhere. Here's how.

The uptime can be found using the command prompt.

Do a start -> Run, punch in cmd and hit Enter (like you normally would).
Type in the command:

net statistics server

(and hit Enter).
Find the line that starts with Statistics since...: it will tell the time the server was up from.

Note that you could shorten the commands like so:

net stats srv

The above has been tested with: Windows 2000 (all versions), Windows XP (all versions), and Windows 2003 (all versions). It will probably work on Vista as well.
edited by on May 21st 2007, at 17:59

Running OpenVPN on Vista, works, but requires some workarounds.
Current list of issues:

  • connection gets established, but route addition fails with route addition failed usingCreateIpForwardEntry

Read further for the solutions...

connection gets established, but route addition fails with route addition failed usingCreateIpForwardEntry

This problem always occurs on a Vista. What happens is that while the connection does get established, the routes are not being added properly, because of an API change in Vista.
To circumvent the issue, add this line to your OpenVPN config file:

route-method exe

This way, the route addition is called directly using the commandline utility.

edited by on May 17th 2007, at 15:24
Because of (Belgian) providers limiting SMTP (port 25) traffic to their own servers, makes it necessary for us (as an 3rd party ISP) to allow our customers to use our own mailserver for all outgoing mail. To circumvent this limitation, we've configured the mailserver to listen on port 26 as well.

For our customers with only a few mail clients (so no local mailserver), this is usually not a problem. A quick change of the SMTP port, solves their issues. For people that have a catch-all mailbox (and a local mailserver), the mailserver itself usually allows the change.

Of course, some of our clients have Exchange servers, and there, the change was not that obvious.
After a bit of a search, we'  ...
edited by on May 14th 2007, at 21:10

It's a bit of an old post, but ran into this problem more than once.
If you get the message:

The system DLL user32.dll was relocated in memory. The application will not run properly. The relocation occurred because the DLL C:\Windows\System32\Hhctrl.ocx occupied an address range reserved for Windows system DLLs. The vendor supplying the DLL should be contacted for a new DLL.

A hot-fix can be downloaded at:

edited by on April 28th 2007, at 00:32
The bliss of dual core can quickly turn to a curse when you're running applications that weren't build to handle multiple CPU's.
Although one could set affinity with windows task manager, the application often goes down before one could alt-tab to set it, or sometimes, the application doesn't even start at all.

A quick search on the web has brought me on a forum thread, where they were talking about RunOnProcessorExplicit, or in short: ROPE.
ROPE is a very simple tool, that allows you to set affinity directly at the start of an application. This circumvents the need of using windows task manager and moreover, allows you to change shortcuts accordingly, so you won't have to remember to set a  ...
edited by on April 28th 2007, at 00:16
When you're running Windows on a system with 4GB RAM, you might have noticed that the entire amount of RAM is not detected (it's somewhere around 3.6GB). This is because of the way HIGHMEM (4GB and up) is handled.
Fortunately, there is a way to solve the problem, allowing the full use of 4GB...

A solution to our problem is by forcibly enabling Intel's Physical Address Extension (in short, PAE). This is done by taking the following steps:

Locate the boot partition (this usually is C: but could be something else): it contains the bootloader files such as ntldr, boot.ini, etc.

Open the boot.ini file, which is in the root of that partition (e.g. c:boot.ini). Note that you might need to change  ...
edited by on April 27th 2007, at 23:50
During the installation of a device (hardware, or a software emulation driver, such as OpenVPN's TAP-Win32 driver), you get the following message:
The system cannot find the file specified.

After that, it goes into a hardware detection loop, meaning it finds and tries to install the same hardware again and again until the cows come home.

Windows 2000 and XP has a bug that it cannot properly install drivers using INF-files, when the RunOnce registry key is missing from the following location:


This key is often used by installers to execute post-reboot scripts and programs, but when these run, they sometimes inadvertently de  ...
edited by on April 27th 2007, at 23:41
When attempting to send a message which is too large for your mail server, it may become stuck in the outbox, unable to delete it, because Outlook says it has already started to send the message.
If this happened to you, there are two things to try...

Try setting Outlook in offline mode:

In the menu, click File, then Offline

Wait about a minute or so, then close and reopen Outlook

If everything went well, you should now be able to delete the message from the outbox, or at least, move it to another folder before attempting to delete it.

When this worked, disable offline mode: click on File in the menu, then again Offline

Finally, restart Outlook and everything should be well again.

If   ...
edited by on April 12th 2007, at 17:36
Uninstalling a managed Symantec Antivirus is no picknick: it requires you to enter a so-called uninstall password, one which of course you never had to enter, or otherwise know about...

After numerous attempts of inserting the local administrator password, the domain admin password, the Symantec Control Center password, etc., I had nowhere to turn but to Google.

After a few searches, I stumbled upon a site explaining steps on how to remove the thing. Preparing myself for a lengthly uninstall process with many steps, the site mentioned between the steps, to try an uninstall using Add/Remove programs in Windows, and if it was a managed install, to use the password symantec.
As I didn't feel   ...
by on January 1st 1970, at 01:00

You can easily trigger SCSI UNMAP in Windows via PowerShell:

Optimize-Volume -DriveLetter C -ReTrim -Verbose
by on January 1st 1970, at 01:00

On a Windows Server with GUI, you can use the traditional method of setting the display resolution but as there's no Control Panel nor Settings app on Windows Server Core, the only way is through Powershell with the Set-DisplayResolution cmdlet.

Set-DisplayResolution -Width 1024 -Height 768

The cmdlet above sets the resolution to 1024x768. It will prompt you to accept the change, if you don't want that, append -Force parameter.

To get the current display resolution, you can use the Get-DisplayResolution cmdlet.

showing posts tagged with 'windows'
« June 2024»
« Smith & Wesson - the original point and click interface »